Logitech C290 Not taking video

  • ** WARNING - ACF CONTAINS ADULT CONTENT **
    Only persons aged 18 or over may read or post to the forums, without regard to whether an adult actually owns the registration or parental/guardian permission. AmberCutie's Forum (ACF) is for use by adults only and contains adult content. By continuing to use this site you are confirming that you are at least 18 years of age.
Status
Not open for further replies.
Jan 8, 2018
16
8
16
I'm beyond frustrated.

I've searched everywhere on the internet and even contacted their customer support. (Which is impossible unless if you actually call.)

Has anyone had their c920 suddenly not take video? When I first got my cam everything worked fine then all of a sudden maybe after an update I'm unable to record footage in the logitech webcam software.

When I go to Longitech Webcam Software -> Quick capture ->Video ->Green button to record ->Countdown happens but the button does not turn red to signal that it is recording and the program does not record.

Anyway, when I contacted customer support they told me that this was a tier 2 issue and I would hear back with in 8-12 DAYS. :mad::mad::rage:
Is there anyway that I can possibly fix it myself ? I'd rather not have to wait.
 

AmberCutie

ACF Owner & Admin. (I don't work for CB.)
Staff member
Cam Model
Mar 1, 2010
23,688
104,677
0
AmberLand (Seattle, WA)
Twitter Username
@amberlynnegirl
MFC Username
AmberCutie
ManyVids URL
https://www.manyvids.com/Profile/1000458969/AmberCutie/
I'm beyond frustrated.

I've searched everywhere on the internet and even contacted their customer support. (Which is impossible unless if you actually call.)

Has anyone had their c920 suddenly not take video? When I first got my cam everything worked fine then all of a sudden maybe after an update I'm unable to record footage in the logitech webcam software.

When I go to Longitech Webcam Software -> Quick capture ->Video ->Green button to record ->Countdown happens but the button does not turn red to signal that it is recording and the program does not record.

Anyway, when I contacted customer support they told me that this was a tier 2 issue and I would hear back with in 8-12 DAYS. :mad::mad::rage:
Is there anyway that I can possibly fix it myself ? I'd rather not have to wait.
In the meantime while you wait for a response from them, try using another third-party software to do your recordings. OBS is probably the most preferable right now.
 
May 8, 2012
1,267
1,118
213
NY
So the camera is not working in any programs?
If so, Do you have another computer you can test the camera with? Or maybe a friend that would let you test the camera on their computer?

If you don't have another computer to test the camera with.
Have you tried rebooting the computer?
Are there any pending windows updates?
Have you tried re-installing the logitech camera drivers?
Does the camera show up as a USB device in device manager?
Have you tried unplugging all other USB devices?
Have you tried every USB port on your computer?
 
Sep 4, 2018
7
0
1
Twitter Username
@9snow2white4
Tumblr Username
devils-candy
I'm not OP but I need help and maybe you can help me?! I just bought a new laptop for camming (hp pavillion) and just hooked up my logitech c920 andddd... it won't work. It let me download the software and stuff, detected that it was plugged up, but when i go to take a picture etc. it says this (pic attached).

I don't need to do any updates, tried redownloading the software and it didn't do anything, it shows up as a USB device in device manager, there is nothing else plugged in to the laptop and I have tried both ports on the computer. I'm about to try turning it off and on but I don't have high hopes. Help me please!! And I have Windows 10.
 

Attachments

May 8, 2012
1,267
1,118
213
NY
I'm not OP but I need help and maybe you can help me?! I just bought a new laptop for camming (hp pavillion) and just hooked up my logitech c920 andddd... it won't work. It let me download the software and stuff, detected that it was plugged up, but when i go to take a picture etc. it says this (pic attached).

I don't need to do any updates, tried redownloading the software and it didn't do anything, it shows up as a USB device in device manager, there is nothing else plugged in to the laptop and I have tried both ports on the computer. I'm about to try turning it off and on but I don't have high hopes. Help me please!! And I have Windows 10.
Have you tried downloading
https://support.logitech.com/en_us/product/hd-pro-webcam-c920/downloads#windowsPnlBar

Have you checked for windows updates?

Have you tried a reboot?

Does it work in another program like OBS?

Have you tried another USB device in the port? Does it work?

You can also contact Logitech Support.
 
Sep 4, 2018
7
0
1
Twitter Username
@9snow2white4
Tumblr Username
devils-candy
I did all of those except OBS, including calling Logitech, who told me it was a Microsoft issue and to call them, who wanted me to pay for service for help so I just hung up without asking... got wine drunk that night and woke up the next morning to it working fine. Thanks, drunken me. You the best.

Sorry for the lack of help to anybody else though because I have no idea what I did.
 
May 8, 2012
1,267
1,118
213
NY
I did all of those except OBS, including calling Logitech, who told me it was a Microsoft issue and to call them, who wanted me to pay for service for help so I just hung up without asking... got wine drunk that night and woke up the next morning to it working fine. Thanks, drunken me. You the best.

Sorry for the lack of help to anybody else though because I have no idea what I did.
Hey at least it's working.
 
Status
Not open for further replies.